Skocz do zawartości
  • Cześć!

    Witaj na forum RootNode - aby pisać u nas musisz się zarejestrować, a następnie zalogować. Posty pisane z kont niezarejestrowanych nie są widoczne publicznie.

Elementor - wolne ładowanie strony


Pawel_15
 Udostępnij

Rekomendowane odpowiedzi

Posiadam stronę stworzoną w Elementorze PRO która pomimo swojej prostoty strasznie wolno działa. Próbowałem już wielu sposobów i żadne póki co nie przyniosły rezultatów.

Serwer na jakim siedzi strona to EWH od dhosting.pl z włączonym skalowaniem które nie jest potrzebne bo paradoksalnie strona zużywa niewielkie zasoby.

Motyw na jakim tworzyłem szablon to Jupiter X Lite + wymagane wtyczki Jupiter X Core oraz Advanced Custom Fields.

Wtyczek jest trochę ale nie są to jakieś kobyły:

- Advanced Custom Fields,

- Contact Form 7,

- Contact Form Widget Elementor,

- Elementor,

- Elementor PRO,

- FileBrid PRO,

- Jupiter X Core,

- Lite Speed Cache,

- Realy Simple SSL Lite,

- Site Kit od Google,

- WP Tryb Konserwacji,

 

Na początku po zainstalowaniu czystego WordPressa wszystko działało poprawnie, potem z biegiem czasu jak tworzyłem kolejne elementy strony to zaczęło wszystko powolnie działać. Samo załadowanie się strony głównej to czasem kilka czy kilkanaście sekund. Nie lepiej wygląda sytuacja z podstronami. Trwa to zdecydowanie za długo pomimo braku czegokolwiek co mogłoby tak spowalniać ładowanie strony i podstron.

Rozważałem opcję że coś nie tak jest z serwerem i pozwoliłem sobie Duplicatorem przenieść całość na serwery RapidDC ale tam strona działała tak samo powolnie.

Próbowałem ustawieniami LS Cache ale koniec końców wysypał mi się szablon i wtyczka póki co jest wyłączona co nie zmieniło czasu ładowania.

Pozwoliłem sobie uruchomić serwer Redis + konfiguracja w WP ale nadal bez poprawy.

Długie ładowanie występuje na stronie/podstronach jak i w panelu administracyjnym. Czytałem że Elementor potrafi nieco zwiększyć obciążenie ale nie sądziłem że aż tak mocno.

Na serwerze mieszczę się bez problemów w podstawowych limitach i mam jeszcze spory zapas i procesora i pamięci RAM.

Narzędzie PageSpeed Insight dla urządzeń mobilnych zwraca wynik 43 a na komputery 67. O ile na urządzeniach mobilnych aż tak bardzo mi nie zależy to już na tym żeby wersja na komputer działała szybko jak najbardziej.

 

Adres strony to https://stacjabak.pl Strona w trakcie budowy, ogarniania.

Co z tym fantem da się zrobić?

Odnośnik do komentarza
Udostępnij na innych stronach

Po wyłączeniu wtyczki Site Kit strona wyraźnie przyśpieszyła. Zależało mi na statystykach na stronie ale skoro spowalniają stronę to trudno.

Dodatkowo zmieniłem ustawienie w Elementorze => Sposób osadzania CSS na osadzenie wewnętrzne.

Page Speed Insight zamiast 60 pokazuje teraz 78 niemniej gdyby było 90 byłbym uradowany. Wersja mobilna może być na żółto, obecnie jest 46 na czerwono.

Odnośnik do komentarza
Udostępnij na innych stronach

Jesteś pewien, że wszystkie 33/20 plików JS musi być ładowane ?

33 żądania Przesłano: 1,64 MB / 350,25 KB 953 ms DOMContentLoaded: 540 ms load: 695 ms < strona głowna
20 żądań Przesłano: 912,12 KB / 251,32 KB 863 ms DOMContentLoaded: 546 ms load: 806 ms < podstrona 

To samo tyczy CSS

12 żądań Przesłano: 759,69 KB / 96,86 KB 769 ms DOMContentLoaded: 636 ms load: 748 ms

 

Może warto je połączyć w jeden/kilka większych.  Pamiętaj, że to TY jesteś webmasterem strony a nie elementor 😁

Odnośnik do komentarza
Udostępnij na innych stronach

37 minut temu, Pawel_15 napisał:

W jaki sposób można te pliki ewentualnie połączyć?

Na ogólnych zasadach najprościej metodą Kopiego > Pasty tworząc jeden większy plik vendora  i jego adres usieliście w szablonie zamiast (n) tych pojedynczych.
IMHO w ciemno powiem, ze w wypadku tak prostej strony jak przedmiotowa powinno wystarczyć samo jquery.... a nawet "Wanila JS". Co innego panel admina., ale to może przeciez rozgraniczyć i o tym decyduje webmaster strony.

BTW to są właśnie uroki elemnetórów - dostajemy  masę zbędnego kodu.

 

może kolejna wtyczka typu https://wordpress.org/plugins/autoptimize/

Edytowane przez Mion
Odnośnik do komentarza
Udostępnij na innych stronach

Nie, na takie grzebanie w kodzie to ja już jestem za stary i zwyczajnie nie ogarniam tematu. 

Zainstalowałem wtyczkę AutoOptimize i teraz wynik w Page Speed dla komórek pokazuje 77 a na komputery 97 co wydaje się być wynikiem zadowalającym.

Wciąż jednak potrafią zdarzyć się delikatne czkawki i wydłużony czas oczekiwania na załadowanie strony.

 

Rozumiem że lepiej by było zamówić szablon stworzony od podstaw na potrzeby tak prostej strony niż bawienie się w Elementory i pochodne.

Odnośnik do komentarza
Udostępnij na innych stronach

A problem nie leży czasem w tym ograniczeniu procka do 1GHz? Bo o ile w perspektywie dużego obciążenia rozłożonego w czasie wydaje się to rozsądna wartość, tak skrypty strony wykonują się zwykle w ułamku sekundy, więc chwilowo powinny mieć jak najwięcej CPU do dyspozycji. Dla przykładu taki bench.php wykonuje się na PHP 7.2 ponad 4 sekundy jak user przycięty jest do 1GHz, a bez takiego ograniczenia mniej niż 1 sekundę.

Edytowane przez Kapitan_Bomba
Odnośnik do komentarza
Udostępnij na innych stronach

IMHO Ciemno mowie, że jest to kwestia źle ustawionego cache.  Pierwsze wejście na daną stronę trwa długo następne błyskawicznie... Choć nie zawsze, ale to pewnie wina przeciążonego serwera.  Tak czy inaczej spraw TTL < cza życja> strony w chche. Jeślu nie ma aktualizacji, to możne siedzieć w cache do "bezterminowo" po aktualizacji wyczyścisz cache.

39 minut temu, Pawel_15 napisał:

Rozumiem że lepiej by było zamówić szablon stworzony od podstaw na potrzeby tak prostej strony niż bawienie się w Elementory i pochodne.

NIE to co Osiągnąłeś jest efektem w pełni zadowalającym.

Storna ląduję się naprawdę  szybko i dzięki temu co proponowałem masz 2 pliki JS  a nie 30 na pokład  ;) 

Odnośnik do komentarza
Udostępnij na innych stronach

No trwa jak buduje się cache! Sprawdź jeszcze raz ustawienia cache w tym tej drugiej wtyczki co kaczy pliki. 

 

Na biedę możesz dodać do CRONA wywołanie tych stron przez curl, co będzie podtrzymywać cache. 

Lub utworzyć centralny plik php w którym  w tablicy przekażesz adresy poszczególnych stron do > forach która wywoła file_get_contents();

Odnośnik do komentarza
Udostępnij na innych stronach

21 godzin temu, Pawel_15 napisał:

@Kapitan_BombaMam ustawione skalowanie gdyby była potrzeba więcej mocy ale strona mieści się w pierwotnie przyznanych limitach czyli 1 GHz CPU i 1GB RAM.

A zobacz z ciekawości ile czasu wykonuje się bench.php. Przecież skrypt zmieści się i 100mhz, tylko kwestia tego jak długo będzie się wykonywał. No inna sprawa, że tu dochodzi jeszcze kwestia zapytania MySQL.

Edytowane przez Kapitan_Bomba
Odnośnik do komentarza
Udostępnij na innych stronach

Godzinę temu, Mion napisał:

No trwa jak buduje się cache!

Zatem jak sprawić żeby on się nie budował?

Godzinę temu, Mion napisał:

Lub utworzyć centralny plik php w którym  w tablicy przekażesz adresy poszczególnych stron do > forach która wywoła file_get_contents();

Nie mam zielonego pojęcia o co chodzi.

 

@Kapitan_Bomba

Deprecated: Invalid characters passed for attempted conversion, these have been ignored in /home/klient.dhosting.pl/lizakowski/stacjabak.pl-ma3i/public_html/bench.php on line 25 test_math : 0.828 sec.

test_stringmanipulation : 0.503 sec.

test_loops : 0.209 sec.

test_ifelse : 0.211 sec.

--------------------------------------

Total time: : 1.751 sec

 

Zaczynam powoli tracić nadzieję że ta strona będzie działać prawidłowo.

O ile rozumiem że wszelkie Webbuildery zawsze zagracały strony to tego że prosta strona ma takie problemy to już nie rozumiem.

OK, jeszcze na jakimś śmiesznie słabym serwerze ale EWH nie należy do jakiejś lipy przecież.

Odnośnik do komentarza
Udostępnij na innych stronach

1 minutę temu, Pawel_15 napisał:

O ile rozumiem że wszelkie Webbuildery zawsze zagracały strony to tego że prosta strona ma takie problemy to już nie rozumiem.


Prosty jest content i layout strony, ale sama strona jako konglomerat HTML+CSS+JS+PHP w postaci zagraconego wtyczkami CMS'a nie jest już prosta.

Odnośnik do komentarza
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się
 Udostępnij

  • Przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników przeglądających tę stronę.

×
×
  • Dodaj nową pozycję...

Powiadomienie o plikach cookie

Korzystając z forum, wyrażasz zgodę na: Warunki użytkowania, Regulamin, Polityka prywatności.