Skocz do zawartości
kacperq

Błędy na stronie - czy ktoś możę zweryfikować?

Polecane posty

Cześć!

Ostatnio pewna osoba powiedziała mi, że przy wchodzeniu na moją stronę w konsoli wywala jej masę błędów (CSS), a nawet czasami nie wczytuje się po wejściu na nią z wyników wyszukiwania Google.

Ja u siebie nie widzę żadnych problemów i nie jestem w stanie ich odtworzyć. Czy może ktoś zerknąć i potwierdzić, czy wszystko jest ok, czy jednak coś się krzaczy?

 

Oto mój portal: https://tinyurl.com/y8bcvygc

 

Będę wdzięczny :)

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

No właśnie mówię, że nie jestem w stanie ich odtworzyć - bo ja ich nie widzę, tylko podobno ktoś inny. Co jest złego w skracaczu? ;)

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Linux/Opera widzę tylko jakieś dwa błędy dotyczące Google Analytics

Linux/Firefox mam jakieś warningi dotyczące JavaScriptu, ale ogólnie działa i błędów nie ma. Udało mi się raz  zarejestrować błąd że nie może załadować https://www.gameron.pl/wp-content/plugins/gdpr-cookie-compliance/dist/scripts/lity.js (dziś pomiędzy 8:45 a 9:00 z IP 188.146.169.189 ). Sprawdź czy widzisz to w logach.

 

Pierwsze co powinieneś zrobić to: logi, logi, logi.

Drugie to ustalić z tą osobą jakiej przeglądarki używa, na jakim łączu, co robiła i spróbować jednak odtworzyć błąd.

 

Rozważałeś, że coś jest nie tak z serwerem albo okazyjnie dobija do jakichś limitów ? Co to za serwer? Hosting współdzielony?

 

PS. Udało mi się nie załadować całej strony. Przy pełnym odświeżeniu o 9:05, pusta strona, jeden błąd:

Loading failed for the <script> with source “https://www.gameron.pl/wp-includes/js/jquery/jquery.js”.

Ale nie wykluczam, że to moje łącze (jestem na LTE TMobile)

Edytowano przez nnd.newbie

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Możliwe ,że temu komuś nie załadował się jakiś plik/element strony (problem z łączem albo  przeglądarką)

 

A jak już tak szczegółowo czepiać się błędów w kodzie to można użyć tego narzędzia i spełniać w 100% w3c  :) chociaż niektóre warningi trzeba traktować z przymróżeniem oka :) ...ale takie kwiatki jak color:#blank albo <style> gdzieś w body to jednak warto wyeliminować :)

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
1 godzinę temu, nnd.newbie napisał:

Linux/Opera widzę tylko jakieś dwa błędy dotyczące Google Analytics

Linux/Firefox mam jakieś warningi dotyczące JavaScriptu, ale ogólnie działa i błędów nie ma. Udało mi się raz  zarejestrować błąd że nie może załadować https://www.gameron.pl/wp-content/plugins/gdpr-cookie-compliance/dist/scripts/lity.js (dziś pomiędzy 8:45 a 9:00 z IP 188.146.169.189 ). Sprawdź czy widzisz to w logach.

 

Pierwsze co powinieneś zrobić to: logi, logi, logi.

Drugie to ustalić z tą osobą jakiej przeglądarki używa, na jakim łączu, co robiła i spróbować jednak odtworzyć błąd.

 

Rozważałeś, że coś jest nie tak z serwerem albo okazyjnie dobija do jakichś limitów ? Co to za serwer? Hosting współdzielony?

 

PS. Udało mi się nie załadować całej strony. Przy pełnym odświeżeniu o 9:05, pusta strona, jeden błąd:


Loading failed for the <script> with source “https://www.gameron.pl/wp-includes/js/jquery/jquery.js”.

Ale nie wykluczam, że to moje łącze (jestem na LTE TMobile)

Hmm, widzę ten błąd pomiędzy 8:45 a 9:00, ale nie mam pojęcia czym jest spowodowany.

 

Dowiedziałem się już wszystkiego od tej osoby, ale nadal nawet na takich samych ustawieniach nie jestem w stanie odtworzyć tego błędu.

 

Serwer nie dobija do żadnych limitów, to EWH w dhosting.

 

A co do problemu z załadowaniem strony - co tu może być powodem, zakładając, że to nie Twoje łącze?

1 godzinę temu, Rafiki napisał:

Możliwe ,że temu komuś nie załadował się jakiś plik/element strony (problem z łączem albo  przeglądarką)

 

A jak już tak szczegółowo czepiać się błędów w kodzie to można użyć tego narzędzia i spełniać w 100% w3c  :) chociaż niektóre warningi trzeba traktować z przymróżeniem oka :) ...ale takie kwiatki jak color:#blank albo <style> gdzieś w body to jednak warto wyeliminować :)

Postaram się to wszystko poprawić, dzięki :) To faktycznie zabawne kwiatki.

38 minut temu, szmigieldesign napisał:

Nie, nie używam tej wtyczki 😉

EDIT: wyłączyłem opcję " Wyklucz JQuery " z LSCache, wydaje mi się, że to ona mogła powodować ten błąd.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

A o pisze w logach? Tam powinna być odpowiedź. Jeśli wina była po mojej stronie to nie powinno być śladu w logach, po prostu łącze mi padło, ewentualnie będzie informacja o zresetowanym połączeniu. Jeśli problem po stronie serwera to szukaj odpowiedzi w logach. Tam powinien być status błędu, czasami z dodatkowym komentarzem. Tutaj masz listę możliwych błędów HTTP: https://en.wikipedia.org/wiki/List_of_HTTP_status_codes

 

Jak nie będziesz wiedział co z tym zrobić to zbierz te logi z błędami i zgłoś do dhosting z opisem problemu.

 

Jak ani ty ani oni nie będziecie w stanie tego wyjaśnić to radziłbym ci przenieść stronę tymczasowo na inny hosting i sprawdzić czy tam też się będzie powtarzać.

 

Obstawiam, że o ile ten osobnik który ci zgłaszał  nie ma coś zwalonego ze swoim łączem/przeglądarką, to biorąc pod uwagę, że błędy pojawiają się okazyjnie i są związane z (jak się wydaje) nie doczytywaniem plików obstawiam, że chyba jednak jakieś ograniczenia/problemy na hostingu. Ale to tylko wróżenie.

Edytowano przez nnd.newbie

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

@kacperq, w lscache w zakładce CDN jest opcja serwowania jquery po cdn - wtyczka filtruje zapytania i ładuje je przez Google CDN i chyba jeszcze cdnjs do wyboru - jeżeli problem był z jquery, warto sprawdzić. Sprawdź też w zakładce optymalizacja czy przypadkiem nie ładujesz minifikowanych skryptów przed innymi, może tam jest jakiś konflikt.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
3 godziny temu, nnd.newbie napisał:

A o pisze w logach? Tam powinna być odpowiedź. Jeśli wina była po mojej stronie to nie powinno być śladu w logach, po prostu łącze mi padło, ewentualnie będzie informacja o zresetowanym połączeniu. Jeśli problem po stronie serwera to szukaj odpowiedzi w logach. Tam powinien być status błędu, czasami z dodatkowym komentarzem. Tutaj masz listę możliwych błędów HTTP: https://en.wikipedia.org/wiki/List_of_HTTP_status_codes

 

Jak nie będziesz wiedział co z tym zrobić to zbierz te logi z błędami i zgłoś do dhosting z opisem problemu.

 

Jak ani ty ani oni nie będziecie w stanie tego wyjaśnić to radziłbym ci przenieść stronę tymczasowo na inny hosting i sprawdzić czy tam też się będzie powtarzać.

 

Obstawiam, że o ile ten osobnik który ci zgłaszał  nie ma coś zwalonego ze swoim łączem/przeglądarką, to biorąc pod uwagę, że błędy pojawiają się okazyjnie i są związane z (jak się wydaje) nie doczytywaniem plików obstawiam, że chyba jednak jakieś ograniczenia/problemy na hostingu. Ale to tylko wróżenie.

Wydaje mi się, że to jednak wina LS Cache - coś pewnie źle ustawiłem, teraz badam temat.

8 minut temu, szmigieldesign napisał:

@kacperq, w lscache w zakładce CDN jest opcja serwowania jquery po cdn - wtyczka filtruje zapytania i ładuje je przez Google CDN i chyba jeszcze cdnjs do wyboru - jeżeli problem był z jquery, warto sprawdzić. Sprawdź też w zakładce optymalizacja czy przypadkiem nie ładujesz minifikowanych skryptów przed innymi, może tam jest jakiś konflikt.

Wyłączyłem wspomnianą opcję - jesteś w stanie sprawdzić, czy nadal można wywołać ten błąd?

Co do zakładki optymalizuj w LScache, tak to wygląda u mnie:

evk6Yhe.jpg

 

Wydaje mi się, że wszystko jest tu ok, ale wole się upewnić. Co sądzisz?

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
  • Dlaczego nie łączysz CSS / JS? Miałeś z tym problemy?
  • Jeżeli jesteś na dhosting, możesz też włączyć HTTP/2 push.
  • Zmieniałeś coś w [6] Tuning względem wartości domyślnych? Ładowanie minifikowanego kodu przed innym może powodować problemy w ładowaniu treści bo zmieniasz kolejność skryptów.
  • Po zmianie ustawień minify / tuning, etc. konieczne jest wyczyszczenie całej pamięci podręcznej.
  • Jedyne błędy jakie widzę u siebie dotyczą Google Ads (403 podczas ładowania zasobów ads) - pomyśl o dodaniu frazy "googleads" do wyjątków js/css.
  • Nie wiem czy korzystasz z optymalizacji obrazów, jeśli nie, zapraszam do mojego krótkiego poradnika - https://szmigiel.design/pl/blog/skuteczna-optymalizacja-grafik-w-wordpress-dzieki-wtyczce-litespeed-cache/

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

1. Tak, strona się wykrzaczała, a ja nie mam nerwów żeby szukać wadliwych plików i ich wykluczać.

2. Po włączeniu tej opcji też niestety strona się krzaczy.

3. Zakładka tuning wygląda u mnie tak:

smvg7wQ.jpg

Coś jest źle?

4. Jasne, wiem.

5. Zrobione. Możesz potwierdzić, czy nadal widzisz te błędy? Chociaż obstawiam, że to jest spowodowane tym, że nadal czekam na zaakceptowanie strony do Adsense i reklamy po prostu jeszcze się nie wyświetlają.

6. Tak, mam abonament na Shortpixela (chciałem coś co optymalizuje zdjęcia automatycznie, dlatego LSCache odpada).

 

 

Edytowano przez kacperq

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

HTTP/2 nie powinno wykrzaczać layoutu. Zwykle layout się sypie kiedy optymalizujesz jQuery, dlatego w lscache jest osobna opcja wykluczająca jQuery ze wszystkich optymalizacji. Ale faktycznie może być potrzebne głębsze zbadanie tematu i wykluczanie poszczególnych js/css. Pisałeś do HD w tej sprawie?

 

Tak to wygląda u mnie (zał.). Sugeruję wykluczyć też googlesyndication z optymalizacji.

 

lscache pozwala na automatyczną optymalizację obrazków od 1200 kredytów (level 3), ale funkcja ta została dodana niedawno, więc jeśli wcześniej badałeś temat to mogłeś o tym nie wiedzieć.

2018-12-15.png

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Dołącz do rozmowy

Możesz pisać i zarejestrować się później. Jeśli masz konto,Zaloguj się teraz, aby publikować na swoim koncie.

Gość
Odpowiedz...

×   Wklejony jako tekst z formatowaniem.   Wklej jako zwykły tekst

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.


  • Kto przegląda   0 użytkowników

    Brak zalogowanych użytkowników przeglądających tę stronę.

×
×
  • Utwórz nowe...

Ważne informacje

Korzystając z forum, wyrażasz zgodę na: Warunki korzystania z serwisu, Regulamin, Polityka prywatności.