Skocz do zawartości
  • Cześć!

    Witaj na forum RootNode - aby pisać u nas musisz się zarejestrować, a następnie zalogować. Posty pisane z kont niezarejestrowanych nie są widoczne publicznie.

Problem z uruchomieniem proftpd debian


dzagu
 Udostępnij

Rekomendowane odpowiedzi

Siemanko, mam problem z odpaleniem proftpd.

Odpalam serwer poleceniem: service proftpd start, nie wyskakuje żaden błąd.

Polecenie: systemctl status proftpd.service -l wypluło taki błąd:

● proftpd.service - LSB: Starts ProFTPD daemon
   Loaded: loaded (/etc/init.d/proftpd; generated; vendor preset: enabled)
   Active: active (exited) since Fri 2019-02-15 23:06:55 CET; 2min 19s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 339 ExecStop=/etc/init.d/proftpd stop (code=exited, status=0/SUCCESS)
  Process: 366 ExecStart=/etc/init.d/proftpd start (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/proftpd.service

Feb 15 23:06:55 ewel systemd[1]: Starting LSB: Starts ProFTPD daemon...
Feb 15 23:06:55 ewel systemd[1]: Started LSB: Starts ProFTPD daemon.
Feb 15 23:09:00 ewel systemd[1]: proftpd.service: Failed to set invocation ID on control group /system.slice/proftpd.service, ignoring: Operation not permitted

Możecie mnie jakoś naprowadzić co się dzieje?

Odnośnik do komentarza
Udostępnij na innych stronach

Cześć, istnieje bardzo podobny wątek dotyczący aplikacji OpenVPN gdzie poruszony został identyczny problem i znajdziesz tam także rozwiązanie które powinno być skuteczne również dla ProFTPD.

 

https://github.com/Angristan/OpenVPN-install/issues/77

 

Rozwiązanie tego problemu dla OpenVPN jest w poniższym komentarzu

https://github.com/angristan/openvpn-install/commit/c703d41795def39b81b4a4ec6b2bda3f144b2a0a#commitcomment-25086118

 

Analogicznie możesz rozwiązać ten problem dla ProFTPD zamieniając jedynie w poleceniach "openvpn" na "proftpd". Daj znać czy pomogło :)

Odnośnik do komentarza
Udostępnij na innych stronach

16 godzin temu, Poziomecki napisał:

Ustaw hostname na jakąś pełną domenę. Bo zapewne o to chodziło leszczowi.

Nie, chodziło mi o to, że wada ta występuje w kernelach instalowanych podczas tworzenia kontenerka OpenVZ :) 

Odnośnik do komentarza
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się
 Udostępnij

  • Ostatnio przeglądający   0 użytkowników

    • Brak zarejestrowanych użytkowników przeglądających tę stronę.
×
×
  • Dodaj nową pozycję...

Powiadomienie o plikach cookie

Korzystając z forum, wyrażasz zgodę na: Warunki użytkowania, Regulamin, Polityka prywatności.