Skocz do zawartości
  • Cześć!

    Witaj na forum RootNode - aby pisać u nas musisz się zarejestrować, a następnie zalogować. Posty pisane z kont niezarejestrowanych nie są widoczne publicznie.

Problem ze strona 404


Rafi
 Udostępnij

Rekomendowane odpowiedzi

Witajcie mam kolejny problem ze stroną mianowicie po ustawieniu virtual hosta pojawia się błąd 404 i nie wiem czemu 

mój config wygląda tak adres to .panel.wemp.pl

 

#proxy_cache_path /tmp/nginx levels=1:2 keys_zone=static:10m inactive=4h max_size=1g;
#proxy_cache_key "$request_method$host$request_uri";
server {
	listen   80; 
	listen 443 ssl http2;
	include ssl-wemppl;

	gzip on;
	gzip_disable "msie6";

	gzip_vary on;
	gzip_proxied any;
	gzip_comp_level 6;
	gzip_buffers 16 8k;
	gzip_types text/plain text/css application/json application/x-javascript application/javascript text/xml application/xml application/xml+rss text/javascript;
	
	root /var/www/html/wemppl; 
	index index.php index.html;

	server_name wemp.pl api.wemp.pl panel.wemp.pl 10.94.94.103; 

	#location / {
		#proxy_set_header X-Real-IP  $remote_addr;
		#proxy_set_header X-Forwarded-For $remote_addr;
		#proxy_set_header Host $host;
		#proxy_pass http://127.0.0.1:8080;
	#}
	#location /ajax/chat {
		#fastcgi_pass 127.0.0.1:9000;
		#include fastcgi.conf;
	#}
	location = /ajax/chat/chatMessages.php {
		fastcgi_pass unix:/var/run/php5-fpm.sock;
		include fastcgi.conf;
	}
	#rewrite ^/v2/(.*)/streamInfo$ /api/v2/stream.php?name=$1 last;
	#location = /api/v2/stream.php {
		#fastcgi_pass unix:/var/run/php5-fpm.sock;
		#include fastcgi.conf;
	#}
	location = /ajax/stream/viewers.php {
		fastcgi_pass unix:/var/run/php5-fpm.sock;
		include fastcgi.conf;
	}
	location = /ajax/privatemessages/getUnreadMessages.php {
		fastcgi_pass unix:/var/run/php5-fpm.sock;
		include fastcgi.conf;
	}
	location = /ajax/privatemessages/getMessagesList_html.php {
		fastcgi_pass unix:/var/run/php5-fpm.sock;
		include fastcgi.conf;
	}
	#location = /ajax/stream/viewers.php {
	#	fastcgi_pass unix:/var/run/php5-fpm.sock;
	#	include fastcgi.conf;
	#}
	location /.well-known {
		alias /var/www/html/wemppl/.well-known;
	}
	location /nginx-status {
		stub_status on;
		access_log off;
	}
	location ~* \.(eot|ttf|woff|woff2)$ {
		add_header Access-Control-Allow-Origin *;
	}
	location / {
		try_files $uri @proxy;
	}
	location ~* \.(js|css|jpg|jpeg|gif|png|svg|ico|pdf|html|htm)$ {
		expires      14d;
#		proxy_pass http://127.0.0.1:8080;
#		proxy_set_header Host $host;
#		proxy_cache static;
#		proxy_cache_valid 200 1d;
#		add_header X-Proxy-Cache $upstream_cache_status;
	}
	location @proxy {
		proxy_pass http://127.0.0.1:8081;
		include /etc/nginx/proxy_params;
	}
	location ~* \.php$ {
		proxy_pass http://127.0.0.1:8080;
		fastcgi_buffers 16 16k; 
		fastcgi_buffer_size 32k;
		include /etc/nginx/proxy_params;
	}
	location ~ /\.ht {
		deny all;
	}
}
server {
	listen   80; 
	listen 443 ssl;
	include ssl-wemppl;
	server_name www.wemp.pl; 
	return 301 http://wemp.pl$request_uri;
}
server {
	listen   80; 
	listen 443 ssl;
	include ssl-wemppl;


	#root /var/www/html/wemppl; 
	index index.php index.html;

	server_name panel.wemp.pl api.wemp.pl; 
	location /.well-known {
		alias /var/www/html/wemppl/.well-known;
	}

	location / {
		proxy_set_header X-Real-IP  $remote_addr;
		proxy_set_header X-Forwarded-For $remote_addr;
		proxy_set_header Host $host;
		proxy_set_header REMOTE_ADDR $remote_addr;
		proxy_pass http://10.94.94.101:80;
	}
	location ~ /\.ht {
		deny all;
	}
}
server {
	listen   80; 
	listen 443 ssl http2;
	include ssl-wemppl;

	location /.well-known {
		alias /var/www/html/wemppl/.well-known;
	}

	#root /var/www/html/wemppl; 
	index index.php index.html;

	#server_name img.wemp.pl; 

	location /preview {
		proxy_set_header X-Real-IP  $remote_addr;
		proxy_set_header X-Forwarded-For $remote_addr;
		proxy_set_header Host $host;
		proxy_set_header REMOTE_ADDR $remote_addr;
		proxy_pass http://10.94.94.101:80;
	}
	location ~ /\.ht {
		deny all;
	}
}

 

Odnośnik do komentarza
Udostępnij na innych stronach

1. masz dobrze skonfigurowane dns ? (odpowiednio ustawiony rekord A tak aby subdomena wczytywała i wskazywała dobrze to co ma)

2. sprawdź ścieżkę do folderu czy jest prawidłowa i czy zgadzają się uprawnienia

3. sprawdź error logi nginx

 

....swoją drogą niezły syf masz w tym configu :)

Odnośnik do komentarza
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się
 Udostępnij

  • Ostatnio przeglądający   0 użytkowników

    • Brak zarejestrowanych użytkowników przeglądających tę stronę.
×
×
  • Dodaj nową pozycję...

Powiadomienie o plikach cookie

Korzystając z forum, wyrażasz zgodę na: Warunki użytkowania, Regulamin, Polityka prywatności.