Skocz do zawartości
  • Cześć!

    Witaj na forum RootNode - aby pisać u nas musisz się zarejestrować, a następnie zalogować. Posty pisane z kont niezarejestrowanych nie są widoczne publicznie.

nextcloud używa php_exec() (?)


chudzik
 Udostępnij

Rekomendowane odpowiedzi

Witam. Używam Nextclouda w wersji 16.0.3 . Od pewnego czasu po zalogowaniu przestało mi wyświetlać pliki tylko zaczęło wywalać błąd:

Ten katalog jest niedostępny, sprawdzić logi lub skontaktuj się z administratorem

no to jak każe komunikat sprawdzam log a tam:

"message":"shell_exec() has been disabled for security reasons at ...

no to włączyłem ten php_exec no bo akurat mam taką możliwość i po włączeniu wszystko działa jak należy.  Jednak mam pewne obawy bo:

1. Wszyscy radzą aby nie włączać tej funkcji bo kwestie bezpieczeństwa

2. Nextcloud radził sobie wcześniej bez tej funkcji a tu nagle potrzebuje.

Dziwne. Jest jakieś sensowne wyjaśnienie tej sytuacji? Można w miarę bezpiecznie pozostawić tę funkcję włączoną?

Odnośnik do komentarza
Udostępnij na innych stronach

Postanowiłem usunąć wszystkie pliki z katalogu głównego strony, wyczyściłem bazę mysql. Postawiłem całą instancję na nowo, na czysto i ... dokładnie to samo. Nie wyświetla przykładowych danych tylko wywala

Ten katalog jest niedostępny, sprawdzić logi lub skontaktuj się z administratorem

A w logu

{"reqId":"Hd9CQVEQpD8t3pAO4WFW","level":3,"time":"2019-08-11T05:21:54+00:00","remoteAddr":"92.19.44.148","user":"skrzacik","app":"PHP","method":"GET","url":"\/index.php\/apps\/gallery\/config?extramediatypes=1","message":"shell_exec() has been disabled for security reasons at [cenzura autora]\/lib\/private\/PreviewManager.php#396","userAgent":"Mozilla\/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko\/20100101 Firefox\/68.0","version":"16.0.3.0"}
{"reqId":"psO6d3ABzDcup43KrdWg","level":3,"time":"2019-08-11T05:21:54+00:00","remoteAddr":"92.19.44.148","user":"skrzacik","app":"PHP","method":"PROPFIND","url":"\/remote.php\/dav\/files\/skrzacik\/","message":"shell_exec() has been disabled for security reasons at [cenzura autora]/public_html\/lib\/private\/PreviewManager.php#396","userAgent":"Mozilla\/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko\/20100101 Firefox\/68.0","version":"16.0.3.0"}

 

Odnośnik do komentarza
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się
 Udostępnij

  • Ostatnio przeglądający   0 użytkowników

    • Brak zarejestrowanych użytkowników przeglądających tę stronę.
×
×
  • Dodaj nową pozycję...

Powiadomienie o plikach cookie

Korzystając z forum, wyrażasz zgodę na: Warunki użytkowania, Regulamin, Polityka prywatności.