Skocz do zawartości
Marceli99

Konfiguracja nginxa pod symfony, różnica Arch i Debian

Polecane posty

Przyznam szczerze, że nginx mnie zniszczył. Mam taki config dla drugiego serwera postawionego na Archu. Tam działa pojedyncza apka napisana w symfony. Mam też osobny serwer gdzie chciałem przenieść tę aplikację i uruchomić dwie pozostałe - Debian 9. Zamysł był taki, że serwer posłuży mi jako przechowalnia dem. Ponadto chciałem mieć jeszcze malutki katalog na testowanie skryptów w czystym PHP, no i umieszczałbym tam to co robimy w szkole. Próbowałem przenieść cały config, uprzednio odpowiednio go modyfikując i kasując SSL, ale rezultat był jeden... Biała strona, brak erroru, pusto w logach. Nie znalazłem też informacji jak rozdzielić serwer na katalogi, wystarczy dać location /apka1, location /apka2 ?

 

Oryginalny config, który działa.

#user html;
worker_processes  4;

events {
    worker_connections  4096;
}


http {
    include       mime.types;
    default_type  application/octet-stream;

	index index.php index.html index.htm index.nginx-debian.html;

    sendfile        on;
    #tcp_nopush     on;
	client_max_body_size 8M;
        keepalive_timeout  35;

        ##
        # Gzip Settings
        ##

        gzip on;
        gzip_disable "msie6";
        gzip_vary on;
        gzip_proxied any;
        gzip_comp_level 9;
        gzip_buffers 16 8k;
        gzip_http_version 1.1;
   
	server{
          listen 80;
	  server_name localhost;
	  return 301 https://www.domena.pl$request_uri;
	}


	server {
          listen 443 ssl;
          server_name  domena.pl www.domena.pl;
		
        error_page      404 /404.php;

	  ssl_protocols TLSv1.1 TLSv1.2;
	  ssl_certificate /etc/letsencrypt/live/www.domena.pl/fullchain.pem;
	  ssl_certificate_key /etc/letsencrypt/live/www.domena.pl/privkey.pem;

          root  /usr/share/nginx/html/public; # pod symfony
####### SYMFONY #######


   location / {
        try_files $uri $uri/ /index.php$is_args$args;
    }

	  location ~ \.php {
        try_files $uri /index.php =404;
        fastcgi_pass 127.0.0.1:9000;
        fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
        fastcgi_param SCRIPT_NAME $fastcgi_script_name;
        fastcgi_split_path_info ^(.+\.php)(/.+)$;
        fastcgi_index index.php;
        include fastcgi_params;
      }

    location ~ \.php$ {
        return 404;
    }



    error_log /var/log/nginx/symfony_error.log;
    access_log /var/log/nginx/symfony_access.log;
        }
    }

Config na debianie 9.

user www-data;
worker_processes auto;
pid /run/nginx.pid;

events {
    worker_connections  768;
}


http {
    include       mime.types;
    default_type  application/octet-stream;

	index index.php index.html index.htm index.nginx-debian.html;

    sendfile        on;
    #tcp_nopush     on;
	client_max_body_size 8M;
        keepalive_timeout  35;

        ##
        # Gzip Settings
        ##

        gzip on;
        gzip_disable "msie6";
        gzip_vary on;
        gzip_proxied any;
        gzip_comp_level 5;
        gzip_buffers 16 8k;
        gzip_http_version 1.1;
   

	server {
          listen 80;
          server_name uw493.mikr.us;
		
        error_page      404 /404.php;

          root  /var/www/html/chocobb/public; # pod symfony
####### SYMFONY DDWRT #####


   location / {
        try_files $uri $uri/ /index.php$is_args$args;
    }

	  location ~ \.php {
        try_files $uri /index.php =404;
	fastcgi_pass unix:/var/run/php/php7.2-fpm.sock;
        fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
        fastcgi_param SCRIPT_NAME $fastcgi_script_name;
        fastcgi_split_path_info ^(.+\.php)(/.+)$;
        fastcgi_index index.php;
        include fastcgi_params;
      }

    location ~ \.php$ {
        return 404;
    }



    error_log /var/log/nginx/symfony_error.log;
    access_log /var/log/nginx/symfony_access.log;
        }
    }

Tym razem zwraca mi error 502, a logi święcą pustką.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Dołącz do rozmowy

Możesz pisać i zarejestrować się później. Jeśli masz konto,Zaloguj się teraz, aby publikować na swoim koncie.

Gość
Odpowiedz...

×   Wklejony jako tekst z formatowaniem.   Wklej jako zwykły tekst

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.


  • Kto przegląda   0 użytkowników

    Brak zalogowanych użytkowników przeglądających tę stronę.

×
×
  • Utwórz nowe...

Ważne informacje

Korzystając z forum, wyrażasz zgodę na: Warunki korzystania z serwisu, Regulamin, Polityka prywatności.