Skocz do zawartości

szogun

Użytkownicy
  • Liczba zawartości

    79
  • Rejestracja

Reputacja

0 Neutral

Ostatnie wizyty

Blok z ostatnimi odwiedzającymi dany profil jest wyłączony i nie jest wyświetlany użytkownikom.

  1. Tak, problem już ogarnięty
  2. Hej, mam malutki problem. Potrzebuję sobie przekierować subdomene na adres ip + port lecz po utworzeniu virtualhosta i po odpaleniu go ciągle domena wskazuje na adres ip serwera bez portu, przed odpaleniem vh wykonałem kroki aby odpalić moduły a2enmod proxy a2enmod proxy_http a2enmod proxy_balancer a2enmod lbmethod_byrequests systemctl restart apache2 <IfModule mod_ssl.c> <VirtualHost *:443> ServerAdmin [email protected] ServerName panel.xxx.pl ServerAlias www.panel.xxx.pl ProxyPreserveHost On ProxyPass / http://127.
  3. O coś takiego mi właśnie chodzi. Tylko czy teraz to przejdzie jeżeli ts będzie na domena.pl oraz panel na domena.pl
  4. No okej lecz, tutaj jest mała zagwozdka gdyż przy dodawaniu rekordu SRV trzeba wskazać Adres docelowy, który nie może być adresem IP
  5. Hej Zastanawiam się jak ugryźć i rozwiązać problem z dwoma różnymi ip dla jednej domeny, które są przypisane do dwóch różnych serwerów, mianowicie na jednej maszynie utrzymuje panele www i przeróżne strony a na kolejnej maszynie serwery głosowe, Teraz jak uzyskać efekt z domeny xxx na połączenie dla panelu www pod xxx ip oraz do serwerów głosowych dla adresu ip xxxv2 (wszystko jest utrzymywane na głównej domenie bez jakiś tam subdomen)
  6. No niestety nadal, jeżeli jest ktoś chętny do przeanalizowania aplikacji i jej naprawy odpłatnie to z miłą chęcią się na to piszę (aplikacja nie jest jakaś duza raptem nie całe 400 linijek kodu) Niestety ja na swoje możliwości wymiękam aby móc to naprawić
  7. Nie wydaje mi się gdyż ID klienta jest pobierane przy połączeniu Wiesz to nie jest ogólnodostępna aplikacja, mogę jedynie na pw udostępnic kod P.S poprawka aplikacji może być odpłatnie jeżeli bd jakiś rażący błąd
  8. Tak, sprawdzałem i niestety nie znalazłem odpowiedniego rozwiązania tutaj mam kawałek kodu aplikacji, która już w sobie ma domyślnie dodane try: cnx = mysql.connector.connect(**data['database']) except mysql.connector.Error as err: if err.errno == errorcode.ER_ACCESS_DENIED_ERROR: print('Something is wrong with your user name or password') elif err.errno == errorcode.ER_BAD_DB_ERROR: print('Database does not exist') else: print(err) cursor = cnx.cursor(buffered=True)
  9. Hej Od pewnego czasu zmagam się z losowymi crashami aplikacji i już nie wiem co może być przyczyną, poniżej logi z konsoli w momencie zatrzymania się aplikacji raise errors.InternalError("Unread result found") mysql.connector.errors.InternalError: Unread result found Exception in thread Thread-8910: Traceback (most recent call last): File "/usr/local/lib/python3.9/threading.py", line 950, in _bootstrap_inner self.run() File "/usr/local/lib/python3.9/threading.py", line 888, in run self._target(*self._args, **self._kwargs) File "/home/xxx/.local/lib/python3.9/site
  10. Problem chyba rozwiązany, może nie perfekcyjnie ale działa. W pliku my.cnf za komentowałem #bind-address= który się dodaje automatycznie po dodania zewnętrznego hosta, dzięki temu już nie dodaje z automatu wpisu, następnie w etc/mysql/mariadb.conf.d w pliku 50-server.cnf ustawiłem bind-address na ip vpsa gdyż z poradnika 0.0.0.0 nie przechodziło.
  11. Odblokowane porty Tak baza wstała.
  12. Okej coś się ruszyło lecz teraz onnecting to database failed: [2013]: Lost connection to MySQL server at 'reading initial communication packet', system error: 0 Moja konfiguracja [client] port=3306 socket=/var/run/mysqld/mysqld.sock [mysqld_safe] socket=/var/run/mysqld/mysqld.sock [mysqld] user=mysql pid-file=/var/run/mysqld/mysqld.pid socket=/var/run/mysqld/mysqld.sock port=3306 bind-address = 0.0.0.0 basedir=/usr datadir=/var/lib/mysql tmpdir=/tmp lc-messages-dir=/usr/share/mysql log_error=/var/log/mysql/error.log symbolic-links=0 skip-external-lock
  13. Zapomniałem wspomnieć o tym , posiadam dodany host
  14. Hej od paru dni zagościł u mnie cyperpanel do zarządania na vipsie lecz mam malutki problem z nim. Gdy podpinam bazę danych lokalnie to wszystko ładnie śmiga w momencie gdy próbuje połączyć się do niej zewnętrznie mam błędy, spędziłem pół dnia klepiąc przeróżne komendy etc elcz nie znalazłem odpowiedniego sposobu na eliminacje problemu Bład podczas połączenia z bazą: [2003]: Can't connect to MySQL server on 'xxx' (111) Bład podczas połączenia z bazą: [2003]: Can't connect to MySQL server on 'xxx' (113)
  15. Ja się podaje przy tym, jeżeli ktoś chętny się znajdzie aby pomóc odpłatnie to naprawić to zapraszam do kontaktu
×
×
  • Dodaj nową pozycję...

Powiadomienie o plikach cookie

Korzystając z forum, wyrażasz zgodę na: Warunki użytkowania, Regulamin, Polityka prywatności.