Skocz do zawartości
Krzysiek

Woocommerce - import/export separator

Rekomendowane odpowiedzi

Napisano (edytowane)

Dzień dobry, potrzebuję pomocy. Próbuję przenieść produkty w woocommerce za pomocą opcji eksportu/importu. Część produktów przenosi się ok, włącznie ze zdjęciami, kategoriami itp. z częścią niestety ale mam problem. Zdjęcia nie mogą się poprawnie skopiować. Zauważyłem, że dotyczy to jedynie produktów, które posiadają galerię zdjęć i poszczególne linki do fotek separowane są za pomocą znaku "|". Nie grzebałem nic w żadnym z kodów, więc instalacja woocommerce jest w zasadzie czysta. Może ktoś miał podobny problem lub ma jakiś pomysł, jak to obejść?

Edit: pytam oczywiście o import z pliku .csv

Edytowane przez Krzysiek

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Najlepszym rozwiązaniem to zrezygnować z Woocomerce :)

 

a tak poważniej to czy problemem nie jest czasem konfiguracja serwera ? (limit czasu wykonywania, limit przesyłanych plików albo ograniczenia pobierania plików z zewnętrznych serwerów)

 

Przeglądałeś wg logi błędów serwera ? - zapewne tam tkwi dokładna odpowiedź na Twój problem :)

  • Super! 1

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Za pomocą jakiego rozwiązania robisz import?

Próbowałeś WP All import?

  • Super! 1

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Póki co import wykonuję bezpośrednio w Woocommerce, próbowałem już kilku wtyczek do importu ale albo nadziewają się na jakiś z limitów na hostingu albo problem dotyczy wersji php, której póki co ze względu na inne strony nie mogę zbytnio zmienić.

W logach serwera nie znalazłem konkretnych komunikatów błędów. Ogólnie produkty przenoszą się bez przeszkód, jedyny problem pojawia się z tymi, które posiadają galerię tzn. kilka odnośników do zdjęć oddzielonych "I". Póki co podmieniłem znak bezpośrednio w pliku .csv i poszło bez problemu. TTych baz będzie jeszcze trochę i każdorazowa weryfikacja i podmiana separatora zabierze trochę czasu.Myślałem, że może ktoś miał podobny problem i znalazł rozwiązanie. Dzięki za zainteresowanie i podpowiedzi ale chyba po prostu będę musiał ręcznie podmieniać to w .csv

Z Woocommerce z chęcią bym już dawno zrezygnował, ale coś nie bardzo na obecnym hostingu mogłem wgrać prestę.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Z tego co piszesz, podstawowym problemem jest hosting. Może warto go zmienić?

Ja zawsze importowałem przez WP All Import i tam nigdy nie było problemu.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
W dniu 11.04.2018 o 11:48, Krzysiek napisał:

Z Woocommerce z chęcią bym już dawno zrezygnował, ale coś nie bardzo na obecnym hostingu mogłem wgrać prestę.

 

Na czym polega problem przy instalacji prestashop?

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
W dniu 13.04.2018 o 09:00, nnd.newbie napisał:

Problem z Prestashop i nie działający import Wordpressa. Niech zgadnę: home.pl?

:)

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Uznaję że tak :)

 

Co do Prestashop to problemem jest nieobsługiwanie przez serwer home.pl dyrektywy FilesMatch w plikach .htaccess. W FAQ home.pl znajdziesz nawet wpis na ten temat: FAQ home.pl. Gdzieś w wątku na rootnode, znajdziesz też temat z dokładnymi informacjami, gdzie i co należy zmienić w Prestashop. 

 

Co do Wordpressa to sporo błędów ze ścieżkami plików jest generowana przez separację lub brak separacji serwisów (opcja do wyklikania w panelu home.pl). Czasami włączenie/wyłączenie tej opcji pomagało. Jak nie, to pozostaje ucieczka albo modyfikacja kodu Wordpress. My ostatecznie wybraliśmy to pierwsze i za home.pl nie tęsknimy.

Edytowane przez nnd.newbie

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Dzięki za link, pomoże mi on wrócić w razie czego do presty :) Wygląda na to, że poddałem się zbyt łatwo. 

Odnośnie Wordpress'a, to póki co kombinowałem właśnie przy kodzie, wprowadzając jakieś drobne modyfikacje. Kilka sklepów na woo, już tam śmigało i większych problemów nie zauważyłem. 

Co by jednak nie mówić, o home to jednak stabilnie ich serwery pracują (przynajmniej ten, na którym mamy hosting).

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się


  • Przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników, przeglądających tę stronę.

×

Powiadomienie o plikach cookie

Korzystając z forum, wyrażasz zgodę na: Warunki użytkowania, Regulamin, Polityka prywatności.