Skocz do zawartości
  • Cześć!

    Witaj na forum RootNode - aby pisać u nas musisz się zarejestrować, a następnie zalogować. Posty pisane z kont niezarejestrowanych nie są widoczne publicznie.

Nietypowy problem, cache rozwala mi stronę


Rekomendowane odpowiedzi

Może Wy coś wymyślicie bo ja wyczerpałem pomysły.

Strona na wp z szablonem premium. Zrobiłem wczoraj aktualizację szablonu, ale że rozwalił mi stronę to przywróciłem ją z kopi (ftp i baza).

Strona nadal rozwalona (terazbiznes.pl) tylko homepage, kategorie i artykuły działają ok.

Piszę do supportu szablonu i odpowiadają że problem z cache, bo na podglądzie działa ok, ale zapisane ustawienia się nie pokazują. No to to się zgadza bo co bym nie zrobił, homepage się nie zmienia. Czy jako homepage ustawie inną podstronę, caly czas pozostaje ono nie zmienione.

Instaluję wtyczkę do wyłączenia strony abym mógł popracować, ale homepage nadal się wyświetla.

 

Czyszczę wp cache non stop, w cloudflare też no i lipa. Co bym nie robił homepage się nie zmienia.

Szukam na ftp nietypowych plików cachujących, ale ich nie ma.

 

Gdy np testuję tą nieszczęsną stronę główną w gtmetrix.com/ to pokazuje mi taką, jaką była ona w grudniu.

google webmaster na podglądzie pokazuje mi że strona jest ok, ale widzi starą stronę główną sprzed kilku dni.

W cache kopia jest z dzisiaj, ale pokazuje home stronę główną nieaktualną.

https://webcache.googleusercontent.com/search?q=cache:J5JnrLjVGTEJ:https://www.terazbiznes.pl/+&cd=1&hl=pl&ct=clnk&gl=pl

 

 

 

Zgłupieć można. WTF?

Odnośnik do odpowiedzi
Udostępnij na innych stronach

Prawdopodobnie masz wyłączoną wtyczkę, która czyta odpowiednio shortcode w zawartości strony - pewnie jakis  page builder (obstawiam Visual Composer).

Jeśli wprowadzasz zmiany to wyłącz całkowicie cache w cloudflare i wszystkie moduły cache'ujące w wordpres. Włącz je na samym końcu gdy wszystko będzie działać.

Kopia w google nie ma nic do rzecz .

  • Lubię 1
Odnośnik do odpowiedzi
Udostępnij na innych stronach

Po przywróceniu kopii sprzed aktualizacji wszystko powinno działać, więc pewnie chodzi o cache cloudflare. Tylko że wszystko cachujące wyłączylem, page builderów na stronie nie było.

 

 

Odnośnik do odpowiedzi
Udostępnij na innych stronach

Ten szablon korzysta z pluginu typu composer, poza tym teraz na stronie widoczne są tagi tzw. shortcode, które nie są parsowane standardowo przez Wordpressa a właśnie przez ten moduł albo jakiś inny dodatkowy wymagany przez Twój szablon "Newspaper" (tagdiv composer?).

U mnie mniej więcej tak wygląda Twoja strona jak w załączniku.

 

 

Screenshot_2021-04-01 TerazBiznes pl - portal o tematyce biznesowej(2).png

Edytowane przez Rafiki
Odnośnik do odpowiedzi
Udostępnij na innych stronach

Tak, jest tagDiv Composer standardowo i jest on włączony. Wszystko ładnie działa w artykułach i kategoriach, tylko padło na stronie głównej no i ten problem z cache.

Kilka minut temu znów przywróciłem kopię zapasową, bez efektu.

 

Mam jeszcze jedną stronę z tym szablonem na tym samym hostingu i tą samą konfiguracją i ona działa ok.

A tak wygląda strona startowa która dotychczas działała jako homepage

 https://www.terazbiznes.pl/startowa2

 

 

 

Odnośnik do odpowiedzi
Udostępnij na innych stronach

Musisz zdiagnozować problem bardziej od strony kodu, czyli zajrzeć pod maskę. Przede wszystkim

  • Dojść do tego z jakiego źródła wyświetlana jet zawartość jaka widać na stronie > ten bałagan
  • Cache może być plikowe, pamięciowe, w bazie danych nawet

Z tego co widzę w kodzie  masz

Cached page generated by WP-Super-Cache on 2021-03-31 21:26:48

 

Wiec już ta wtyczka powoduje jakiś konflikt lub właśnie taki syf jest generowany, a w wtyczka to zapisała jako KOD strony.

Tak czy inaczej wyczyść  WP-Super-Cache

  • Lubię 1
Odnośnik do odpowiedzi
Udostępnij na innych stronach

1. Sprawdź koniecznie w ustawieniach wtyczki Wp Supercache zakładkę Contents i użyj "Clear Cache" oraz "Delete Expired" - spowoduje to usunięcie plików cache utworzonych przez wtyczkę i wczytanie strony od nowa.

2. Wyłącz wtyczkę Autooptimize - jeżeli korzystasz z WP Supercache to użycie Autooptimize może wyrządzić szkody bo to kombajn optymalizujący też CSS, JS'y i inne rzeczy a to działa różnie, zwłaszcza gdy korzystasz z page buildera. Generalnie lepiej używać tylko jednej wtyczki  do optymalizacji strony.

  • Lubię 1
Odnośnik do odpowiedzi
Udostępnij na innych stronach
Cached page generated by WP-Super-Cache on 2021-03-31 21:26:48

 

Chyba właśnie o tej godzinie robiłem aktualizację.

Kiedyś testowałem inną wtyczkę cache i ona też cachowała stronę główną i też opróżnianie cache nic nie dało, ale łatwo było znaleźć powód a był to utworzony plik index.html. W tym przypadku takiego nie ma.

 

1. Wp-supercache czyściłem, wyłączałem, usuwałem katalog /cache na wordpressie i nic nie pomogło.

2. Autoptimize też opróżniałem i wyłączałem, bez rezultatu.

 

Support od szablonu siedzi na ftp i panelu administracyjnym i jeśli oni nic nie zdziałają, to chyba ustawię stronę na nazwadomeny/start

 

 

Odnośnik do odpowiedzi
Udostępnij na innych stronach
Godzinę temu, igorex napisał:

Support od szablonu siedzi na ftp i panelu administracyjnym i jeśli oni nic nie zdziałają, t

Jak dla mnie to sprawa wygląda w ten sposób, że cache nic nie jest winne, gdyż funkcją cache jest zapisanie jakiś danych jakie dostanie na inpucie i tyle.

To wtyczka przygotowująca dane ma jakiś BUG lub niekompatybilność i wywala, to co widać później w cache.

 

System Cache na czas naprawie powinien być w ogolę wyłączony .

 

 

Odnośnik do odpowiedzi
Udostępnij na innych stronach

To cache, support szablonu zamknął sprawę bo to już nie ich problem. Gdy usuwam bazę danych strona oczywiście nie działa, ale strona główna pozostaje.

Przekierowanie które chciałem zrobić na nazwadomeny/start nie działa, nic się nie zmienia.

 

Kurcze nie wiem co robić, hosting zmienić?

Odnośnik do odpowiedzi
Udostępnij na innych stronach

Z tego co widzę strona jest za CloudFlarem - nie masz tam przypadkiem ustawionego cachowania strony, jeśli tak to go wyczyść?

Jeśli to ani wywalenie twojej wtyczki od cache nie pomoże to może być to jakiś błąd szablonu, weź na jakimś hostingu konto testowe np na nazwie i sprawdź na tej samej konfiguracji czy błąd występuje.

Edytowane przez Jakub
Odnośnik do odpowiedzi
Udostępnij na innych stronach

Jakub, jest cloudflare ale jak już piałem, czyszcze cache non stop, bez efektu. Instalowałem również ich plugin do wp, czyściłem przez niego cache, bez efektu.

Aktulne ustawienia mam takie jak na screenach.

I błąd szablonu również to nie jest. Mogę go zmienić na inny, ale co bym nie zrobił, ta strona główna pozostaje niezmienna.

Nawet jak w wp skasuje indeks.php nic to nie daje.

 

 

cache1.png

cache2.png

cache3.png

Odnośnik do odpowiedzi
Udostępnij na innych stronach
https://help.dreamhost.com/hc/en-us/articles/216477847-How-to-clear-or-temporarily-suspend-your-CloudFlare-cache

Tak jak pisze Jakub wyczyść cache CF

Odnośnik do odpowiedzi
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się
  • Ostatnio przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników przeglądających tę stronę.

×
×
  • Dodaj nową pozycję...

Powiadomienie o plikach cookie

Korzystając z forum, wyrażasz zgodę na: Warunki użytkowania, Regulamin, Polityka prywatności.